summaryrefslogtreecommitdiffstats
path: root/VNFs/DPPD-PROX/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'VNFs/DPPD-PROX/meson.build')
-rw-r--r--VNFs/DPPD-PROX/meson.build6
1 files changed, 0 insertions, 6 deletions
diff --git a/VNFs/DPPD-PROX/meson.build b/VNFs/DPPD-PROX/meson.build
index 4a37ad50..15a55691 100644
--- a/VNFs/DPPD-PROX/meson.build
+++ b/VNFs/DPPD-PROX/meson.build
@@ -43,11 +43,7 @@ if get_option('prox_stats').enabled()
endif
if get_option('hw_direct_stats').enabled()
-if dpdk_version.version_compare('<21.11.0')
add_project_arguments('-DPROX_HW_DIRECT_STATS', language: 'c')
-else
- warning('hw_direct_stats not supported on this dpdk version')
-endif
endif
if get_option('dbg')
@@ -179,9 +175,7 @@ sources = files(
'stats_cons_cli.c', 'stats_parser.c', 'hash_set.c', 'prox_lua.c',
'prox_malloc.c', 'prox_ipv6.c', 'prox_compat.c', 'handle_nsh.c')
-if dpdk_version.version_compare('<21.11.0')
sources += files('rw_reg.c')
-endif
# Include a couple of source files depending on DPDK support
if cc.find_library('rte_pmd_aesni', required: false).found()