summaryrefslogtreecommitdiffstats
path: root/VNFs/DPPD-PROX/meson.build
diff options
context:
space:
mode:
authorPatrice Buriez <patrice.buriez@chenapan.org>2023-01-02 12:51:54 +0000
committerPatrice Buriez <patrice.buriez@chenapan.org>2023-01-02 12:51:54 +0000
commita085fb09d70d024413844df9d1c343fdc28ded1d (patch)
treedc3cbe28ca83b205102d4da0ad82e111a8ab0bfb /VNFs/DPPD-PROX/meson.build
parent8912be9d61200a3ad8b30a33e362be963eb8c4bb (diff)
Restore rw_reg and hw_direct_stats
Note that DPDK 21.11 and above must be built with 'enable_driver_sdk' option enabled, in order to expose the rte_eth_devices array, now marked as internal. See http://doc.dpdk.org/guides-21.11/rel_notes/release_21_11.html#abi-changes for details. This is done by supplying the '-Denable_driver_sdk=true' command line parameter, either to 'meson setup', or later on to 'meson configure', before running 'ninja' and 'ninja install'. Signed-off-by: Patrice Buriez <patrice.buriez@chenapan.org> Change-Id: I20db8971818a29ec495b6d8d79cf46f2204631a5
Diffstat (limited to 'VNFs/DPPD-PROX/meson.build')
-rw-r--r--VNFs/DPPD-PROX/meson.build6
1 files changed, 0 insertions, 6 deletions
diff --git a/VNFs/DPPD-PROX/meson.build b/VNFs/DPPD-PROX/meson.build
index 4a37ad50..15a55691 100644
--- a/VNFs/DPPD-PROX/meson.build
+++ b/VNFs/DPPD-PROX/meson.build
@@ -43,11 +43,7 @@ if get_option('prox_stats').enabled()
endif
if get_option('hw_direct_stats').enabled()
-if dpdk_version.version_compare('<21.11.0')
add_project_arguments('-DPROX_HW_DIRECT_STATS', language: 'c')
-else
- warning('hw_direct_stats not supported on this dpdk version')
-endif
endif
if get_option('dbg')
@@ -179,9 +175,7 @@ sources = files(
'stats_cons_cli.c', 'stats_parser.c', 'hash_set.c', 'prox_lua.c',
'prox_malloc.c', 'prox_ipv6.c', 'prox_compat.c', 'handle_nsh.c')
-if dpdk_version.version_compare('<21.11.0')
sources += files('rw_reg.c')
-endif
# Include a couple of source files depending on DPDK support
if cc.find_library('rte_pmd_aesni', required: false).found()