summaryrefslogtreecommitdiffstats
path: root/VNFs/DPPD-PROX/meson.build
diff options
context:
space:
mode:
authorXavier Simonart <simonartxavier@gmail.com>2022-01-02 16:14:40 +0000
committerXavier Simonart <simonartxavier@gmail.com>2022-01-03 15:11:38 +0000
commit9d5f15b0dad8bb19b8c43b3f60f75b82d53e432c (patch)
tree8edd3f2c61914fbdea16fcde284ea510b58b66c0 /VNFs/DPPD-PROX/meson.build
parent971d163b345ab3f74d6a5252722371dc17a8fe7a (diff)
Fix keyboard related issues when building with meson
Signed-off-by: Xavier Simonart <simonartxavier@gmail.com> Change-Id: I8186703b8ea3e88f91cd929898033eafecd686aa
Diffstat (limited to 'VNFs/DPPD-PROX/meson.build')
-rw-r--r--VNFs/DPPD-PROX/meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/VNFs/DPPD-PROX/meson.build b/VNFs/DPPD-PROX/meson.build
index 41cf6553..217a9679 100644
--- a/VNFs/DPPD-PROX/meson.build
+++ b/VNFs/DPPD-PROX/meson.build
@@ -100,6 +100,16 @@ if not lua_dep.found()
error('Suitable lua version not found')
endif
+has_sym_args = [
+ [ 'HAVE_LIBEDIT_EL_RFUNC_T', 'histedit.h',
+ 'el_rfunc_t' ],
+]
+config = configuration_data()
+foreach arg:has_sym_args
+ config.set(arg[0], cc.has_header_symbol(arg[1], arg[2]))
+endforeach
+configure_file(output : 'libedit_autoconf.h', configuration : config)
+
# All other dependencies
dpdk_dep = dependency('libdpdk', required: true)
tinfo_dep = dependency('tinfo', required: false)