summaryrefslogtreecommitdiffstats
path: root/deprecated/setup.py
diff options
context:
space:
mode:
authorGerald Kunzmann <kunzmann@docomolab-euro.com>2017-11-28 11:20:33 +0000
committerGerrit Code Review <gerrit@opnfv.org>2017-11-28 11:20:33 +0000
commita7a703420f552c0df396575e893a319cc0233ea8 (patch)
tree9b0cd1156180772ea4c90c1efabe8dbd08e9dc87 /deprecated/setup.py
parente081a200bc12b4c23d283b1d447dbaa4d73a1228 (diff)
parent3ce698ee20cca69104874d42e64300abe641a27c (diff)
Merge "Proposal to move Promise shim-layer code to a new deprecated folder"
Diffstat (limited to 'deprecated/setup.py')
-rw-r--r--deprecated/setup.py22
1 files changed, 22 insertions, 0 deletions
diff --git a/deprecated/setup.py b/deprecated/setup.py
new file mode 100644
index 0000000..a1e9b3b
--- /dev/null
+++ b/deprecated/setup.py
@@ -0,0 +1,22 @@
+#!/usr/bin/env python
+
+# Copyright (c) 2017 Orange and others.
+#
+# All rights reserved. This program and the accompanying materials
+# are made available under the terms of the Apache License, Version 2.0
+# which accompanies this distribution, and is available at
+# http://www.apache.org/licenses/LICENSE-2.0
+
+import setuptools
+
+# In python < 2.7.4, a lazy loading of package `pbr` will break
+# setuptools if some other modules registered functions in `atexit`.
+# solution from: http://bugs.python.org/issue15881#msg170215
+try:
+ import multiprocessing # noqa
+except ImportError:
+ pass
+
+setuptools.setup(
+ setup_requires=['pbr>=1.8'],
+ pbr=True)