summaryrefslogtreecommitdiffstats
path: root/deprecated/setup.py
diff options
context:
space:
mode:
authorBertrand Souville <souville@docomolab-euro.com>2017-11-27 17:15:54 +0100
committerBertrand Souville <souville@docomolab-euro.com>2017-11-27 17:15:54 +0100
commit3ce698ee20cca69104874d42e64300abe641a27c (patch)
treea5f1e419cdb65b0b1edb4bb06cf9480ada670cab /deprecated/setup.py
parent48c252069be02fe2019633827c8a22cdcd201170 (diff)
Proposal to move Promise shim-layer code to a new deprecated folder
Promise test cases have been disabled in Functest Promise shim-layer has been marked as DEPRECATED in Euphrates Change-Id: I98ecd9ae2b25c102f478fc3869f23e6c70d32d8d Signed-off-by: Bertrand Souville <souville@docomolab-euro.com>
Diffstat (limited to 'deprecated/setup.py')
-rw-r--r--deprecated/setup.py22
1 files changed, 22 insertions, 0 deletions
diff --git a/deprecated/setup.py b/deprecated/setup.py
new file mode 100644
index 0000000..a1e9b3b
--- /dev/null
+++ b/deprecated/setup.py
@@ -0,0 +1,22 @@
+#!/usr/bin/env python
+
+# Copyright (c) 2017 Orange and others.
+#
+# All rights reserved. This program and the accompanying materials
+# are made available under the terms of the Apache License, Version 2.0
+# which accompanies this distribution, and is available at
+# http://www.apache.org/licenses/LICENSE-2.0
+
+import setuptools
+
+# In python < 2.7.4, a lazy loading of package `pbr` will break
+# setuptools if some other modules registered functions in `atexit`.
+# solution from: http://bugs.python.org/issue15881#msg170215
+try:
+ import multiprocessing # noqa
+except ImportError:
+ pass
+
+setuptools.setup(
+ setup_requires=['pbr>=1.8'],
+ pbr=True)