summaryrefslogtreecommitdiffstats
path: root/build/opnfv-apex.spec
diff options
context:
space:
mode:
authorTim Rozet <trozet@redhat.com>2015-12-17 16:59:05 -0500
committerDan Radez <dradez@redhat.com>2016-01-06 13:22:07 -0500
commit37dffdb77dc1424b45fa1fac8a8eebda846b107e (patch)
tree5d37ab2270ebc3e13a0cd5e79fdf72c4ac3caeeb /build/opnfv-apex.spec
parentd71330a6abf114050893d52497a5de05c19d70e1 (diff)
Adds some network parsing for baremetal deployments and other fixes
Changes include: - Fixes Intel Pod 2 inventory file - Check for DHCP server on the host and disable - Adds realistic+common network-settings file - Modifies baremetal deployments to bridge to correct interface - Adds private/storage network OVS bridges - Parses network-settings into valid network-environment variables - If certain network-settings are missing they will be auto-detected Note: The actual settings set forth for deployment only include admin/external networks at the moment. Private/storage networks will be handled in an upcoming patch. JIRA: APEX-50 Change-Id: I0a1a86f37c08702a93fe167688c3149ba5573db4 Signed-off-by: Tim Rozet <trozet@redhat.com>
Diffstat (limited to 'build/opnfv-apex.spec')
-rw-r--r--build/opnfv-apex.spec18
1 files changed, 14 insertions, 4 deletions
diff --git a/build/opnfv-apex.spec b/build/opnfv-apex.spec
index 9b6a6f85..cb9f7705 100644
--- a/build/opnfv-apex.spec
+++ b/build/opnfv-apex.spec
@@ -1,5 +1,5 @@
Name: opnfv-apex
-Version: 2.6
+Version: 2.7
Release: %{release}
Summary: Scripts and Disk images for deployment
@@ -33,12 +33,16 @@ install ci/clean.sh %{buildroot}%{_bindir}/opnfv-clean
mkdir -p %{buildroot}%{_var}/opt/opnfv/stack/
mkdir -p %{buildroot}%{_var}/opt/opnfv/nics/
+mkdir -p %{buildroot}%{_var}/opt/opnfv/lib/
+install lib/common-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
install build/instack.qcow2 %{buildroot}%{_var}/opt/opnfv/stack/
install build/instack.xml %{buildroot}%{_var}/opt/opnfv/
-install build/baremetalbrbm_brbm1_*.xml %{buildroot}%{_var}/opt/opnfv/
+install build/baremetalbrbm_brbm1_brbm2_brbm3_*.xml %{buildroot}%{_var}/opt/opnfv/
install build/brbm-net.xml %{buildroot}%{_var}/opt/opnfv/
install build/brbm1-net.xml %{buildroot}%{_var}/opt/opnfv/
+install build/brbm2-net.xml %{buildroot}%{_var}/opt/opnfv/
+install build/brbm3-net.xml %{buildroot}%{_var}/opt/opnfv/
install build/default-pool.xml %{buildroot}%{_var}/opt/opnfv/
install build/network-environment.yaml %{buildroot}%{_var}/opt/opnfv/
install build/nics/controller.yaml %{buildroot}%{_var}/opt/opnfv/nics/
@@ -55,15 +59,19 @@ install docs/installation-instructions.html %{buildroot}%{_docdir}/opnfv/
install docs/release-notes/index.rst %{buildroot}%{_docdir}/opnfv/release-notes.rst
install docs/release-notes.html %{buildroot}%{_docdir}/opnfv/
install config/deploy/deploy_settings.yaml %{buildroot}%{_docdir}/opnfv/deploy_settings.yaml.example
+install config/deploy/network/network_settings.yaml %{buildroot}%{_docdir}/opnfv/network_settings.yaml.example
%files
%{_bindir}/opnfv-deploy
%{_bindir}/opnfv-clean
+%{_var}/opt/opnfv/lib/common-functions.sh
%{_var}/opt/opnfv/stack/instack.qcow2
%{_var}/opt/opnfv/instack.xml
-%{_var}/opt/opnfv/baremetalbrbm_brbm1_*.xml
+%{_var}/opt/opnfv/baremetalbrbm_brbm1_brbm2_brbm3_*.xml
%{_var}/opt/opnfv/brbm-net.xml
%{_var}/opt/opnfv/brbm1-net.xml
+%{_var}/opt/opnfv/brbm2-net.xml
+%{_var}/opt/opnfv/brbm3-net.xml
%{_var}/opt/opnfv/default-pool.xml
%{_var}/opt/opnfv/network-environment.yaml
%{_var}/opt/opnfv/nics/controller.yaml
@@ -77,9 +85,11 @@ install config/deploy/deploy_settings.yaml %{buildroot}%{_docdir}/opnfv/deploy_s
%doc %{_docdir}/opnfv/release-notes.rst
%doc %{_docdir}/opnfv/release-notes.html
%doc %{_docdir}/opnfv/deploy_settings.yaml.example
-
+%doc %{_docdir}/opnfv/network_settings.yaml.example
%changelog
+* Tue Dec 20 2015 Tim Rozet <trozet@redhat.com> - 2.7-1
+- Modifies networks to include OPNFV private/storage networks
* Tue Dec 15 2015 Dan Radez <dradez@redhat.com> - 2.6-1
- Added deploy settings for flat network config
- cleaned up files that don't need to be in the rpm