aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 5 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index ff415aecd..742192c6f 100644
--- a/setup.py
+++ b/setup.py
@@ -10,7 +10,8 @@ setup(
include_package_data=True,
package_data={'yardstick': ['benchmark/scenarios/networking/*.bash']},
url="https://www.opnfv.org",
- install_requires=["flake8",
+ install_requires=["backport_ipaddress", # remove with python3
+ "flake8",
"PyYAML>=3.10",
"pbr!=0.7,<1.0,>=0.6",
"python-glanceclient>=0.12.0",
@@ -18,14 +19,14 @@ setup(
"python-keystoneclient>=0.11.1",
"python-neutronclient>=2.3.9",
"python-novaclient>=2.24.1",
- "mock>=1.0.1",
+ "mock>=1.0.1", # remove with python3
"paramiko",
"six"
],
- entry_points = {
+ entry_points={
'console_scripts': [
'yardstick=yardstick.main:main',
],
},
- scripts =['tools/yardstick-img-modify']
+ scripts=['tools/yardstick-img-modify']
)