aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorhoujingwen <houjingwen@huawei.com>2015-07-03 07:58:25 +0000
committerhoujingwen <houjingwen@huawei.com>2015-07-06 02:40:51 +0000
commit6b667910909b332e78105ccdf17e39e4b286ed39 (patch)
treeb58a13ad4f8b65dda0e289012c89a7410bd30271 /setup.py
parentbca83ab90d5f6ffb0afe5f2e756e3fd37f85c2a7 (diff)
Add support for measuring storage performance use fio
A simple test case is added that will test writes to ephemeral storage. See samples/fio.yaml The Fio test type can also be used to test block storage, just modify the "filename" argument. JIRA: YARDSTICK-34 Change-Id: I1758d2999f8a5fdd44726e1dfc3e9769ea39dad6 Signed-off-by: houjingwen <houjingwen@huawei.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 6 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 742192c6f..7adaa05dc 100644
--- a/setup.py
+++ b/setup.py
@@ -8,7 +8,12 @@ setup(
version="0.1.dev0",
packages=find_packages(),
include_package_data=True,
- package_data={'yardstick': ['benchmark/scenarios/networking/*.bash']},
+ package_data={
+ 'yardstick': [
+ 'benchmark/scenarios/networking/*.bash',
+ 'benchmark/scenarios/storage/*.bash'
+ ]
+ },
url="https://www.opnfv.org",
install_requires=["backport_ipaddress", # remove with python3
"flake8",