aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorHans Feldt <hans.feldt@ericsson.com>2015-05-22 14:01:37 +0200
committerHans Feldt <hans.feldt@ericsson.com>2015-05-22 14:18:13 +0200
commit5d8f20e7ee76ac56459bc7e37312ebc13fb7cf55 (patch)
treec8dc2f64b24f09af8c18540c9e2097861594c17f /setup.py
parentb873c6c28127202cdb3957e1982f30f4f85d3fe5 (diff)
add main cmd for yardstick
Some necessary setup fixes (after the pbr 1.0.1 release) JIRA: - Change-Id: I6259f7211b2f446e57461b7b6ac0e42387b92f5c Signed-off-by: Hans Feldt <hans.feldt@ericsson.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py10
1 files changed, 8 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 8c16c56ea..688185185 100644
--- a/setup.py
+++ b/setup.py
@@ -5,13 +5,14 @@ ez_setup.use_setuptools()
setup(
name="yardstick",
- version="0.1dev",
+ version="0.1.dev0",
packages=find_packages(),
- scripts=['bin/yardstick'],
include_package_data=True,
+ package_data={'yardstick': ['benchmark/scenarios/networking/*.bash']},
url="https://www.opnfv.org",
install_requires=["flake8",
"PyYAML>=3.10",
+ "pbr!=0.7,<1.0,>=0.6",
"python-glanceclient>=0.12.0",
"python-heatclient>=0.2.12",
"python-keystoneclient>=0.11.1",
@@ -21,4 +22,9 @@ setup(
"paramiko",
"six"
],
+ entry_points = {
+ 'console_scripts': [
+ 'yardstick=yardstick.main:main',
+ ],
+ }
)