aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorwym_libra <yimin.wang@huawei.com>2015-12-07 16:02:18 +0800
committerwym_libra <yimin.wang@huawei.com>2015-12-18 10:09:08 +0800
commit53a96f499680587dc2f6172a964af35f9ce1c74b (patch)
tree0e6326ee1bd7d8e99c0c8ddc3cd0a9b50bb1dc6b /setup.py
parent05c1840c9c4dda154c9c5d00ff3cd23ba202330b (diff)
Rewrite the HA test case (1)
refactor the attacker implement. 1) BaseAttacker is added 2) a simple attacker named "kill-process" inherit the BaseAttacker 3) serviceha.py selects an attacker through the BaseAttacker by attacker name JIRA: YARDSTICK-149 Change-Id: Ib718d5edc6b5e14bc3ea0592e0146468ff70b43e Signed-off-by: wym_libra <yimin.wang@huawei.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 495291cef..654ea0fc4 100755
--- a/setup.py
+++ b/setup.py
@@ -8,7 +8,8 @@ setup(
include_package_data=True,
package_data={
'yardstick': [
- 'benchmark/scenarios/availability/ha_tools/*.bash',
+ 'benchmark/scenarios/availability/attacker/*.yaml',
+ 'benchmark/scenarios/availability/attacker/scripts/*.bash',
'benchmark/scenarios/compute/*.bash',
'benchmark/scenarios/networking/*.bash',
'benchmark/scenarios/storage/*.bash',