summaryrefslogtreecommitdiffstats
path: root/VNFs/DPPD-PROX/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'VNFs/DPPD-PROX/meson.build')
-rw-r--r--VNFs/DPPD-PROX/meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/VNFs/DPPD-PROX/meson.build b/VNFs/DPPD-PROX/meson.build
index 41cf6553..217a9679 100644
--- a/VNFs/DPPD-PROX/meson.build
+++ b/VNFs/DPPD-PROX/meson.build
@@ -100,6 +100,16 @@ if not lua_dep.found()
error('Suitable lua version not found')
endif
+has_sym_args = [
+ [ 'HAVE_LIBEDIT_EL_RFUNC_T', 'histedit.h',
+ 'el_rfunc_t' ],
+]
+config = configuration_data()
+foreach arg:has_sym_args
+ config.set(arg[0], cc.has_header_symbol(arg[1], arg[2]))
+endforeach
+configure_file(output : 'libedit_autoconf.h', configuration : config)
+
# All other dependencies
dpdk_dep = dependency('libdpdk', required: true)
tinfo_dep = dependency('tinfo', required: false)