summaryrefslogtreecommitdiffstats
path: root/utils/test/result_collection_api/tornado_swagger_ui/setup.py
diff options
context:
space:
mode:
authorSerenaFeng <feng.xiaowei@zte.com.cn>2016-05-11 11:48:06 +0800
committerSerena Feng <feng.xiaowei@zte.com.cn>2016-05-11 09:28:03 +0000
commit5993262403014cfd053783cca1ac646089101cc0 (patch)
tree1d83460b35c8b431a364eb464b5cf4dd953906bb /utils/test/result_collection_api/tornado_swagger_ui/setup.py
parentaccf6fb545a8c406cc5cb3f6c6f502d7419fb7b9 (diff)
integration of tornado and swagger-ui
this code will be applied to testApi later, as regards how to use it, please refer utils/test/result_collection_api/tornado_swagger_ui/README.md JIRA: FUNCTEST-247 Change-Id: Ie40e125846add7ceda15f05a38232dc8813b8f29 Signed-off-by: SerenaFeng <feng.xiaowei@zte.com.cn>
Diffstat (limited to 'utils/test/result_collection_api/tornado_swagger_ui/setup.py')
-rw-r--r--utils/test/result_collection_api/tornado_swagger_ui/setup.py31
1 files changed, 31 insertions, 0 deletions
diff --git a/utils/test/result_collection_api/tornado_swagger_ui/setup.py b/utils/test/result_collection_api/tornado_swagger_ui/setup.py
new file mode 100644
index 000000000..97655917c
--- /dev/null
+++ b/utils/test/result_collection_api/tornado_swagger_ui/setup.py
@@ -0,0 +1,31 @@
+try:
+ from setuptools import setup
+except ImportError:
+ from distutils.core import setup
+
+with open('README') as file:
+ long_description = file.read()
+
+setup(name='tornado-swagger',
+ version='1.0',
+ url='https://github.com/SerenaFeng/tornado-swagger',
+ zip_safe=False,
+ packages=['tornado_swagger'],
+ package_data={
+ 'tornado_swagger': [
+ 'static/*.*',
+ 'static/css/*.*',
+ 'static/images/*.*',
+ 'static/lib/*.*',
+ 'static/lib/shred/*.*',
+ ]
+ },
+ description='Extract swagger specs from your tornado project',
+ author='Serena Feng',
+ license='MIT',
+ long_description=long_description,
+ install_requires=[
+ 'tornado>=3.1',
+ 'epydoc>=0.3.1'
+ ],
+)