summaryrefslogtreecommitdiffstats
path: root/xci/playbooks/roles/configure-network/templates/debian/controller00.interface.j2
diff options
context:
space:
mode:
authorMarkos Chandras <mchandras@suse.de>2018-02-15 08:57:47 +0000
committerMarkos Chandras <mchandras@suse.de>2018-02-21 17:37:05 +0000
commitcdcfb32414af77abac43440e0ab5b448e72d83e5 (patch)
tree600f06e58f54db46be3072794237762eb02e72e1 /xci/playbooks/roles/configure-network/templates/debian/controller00.interface.j2
parent7c37b9ac8715ebedecf903f9de67c55830fb5b90 (diff)
xci: roles: configure-network: Determine host NIC from Ansible facts
Hardcoding the interface as a variable is very fragile since it varies from host to host. We could use the Ansible facts to find out the interface name and then use that to configure all the VLANs and networking. Change-Id: Ie7e2409d638625b9bede23b6c1fe33dc36f81840 Signed-off-by: Markos Chandras <mchandras@suse.de>
Diffstat (limited to 'xci/playbooks/roles/configure-network/templates/debian/controller00.interface.j2')
-rw-r--r--xci/playbooks/roles/configure-network/templates/debian/controller00.interface.j230
1 files changed, 15 insertions, 15 deletions
diff --git a/xci/playbooks/roles/configure-network/templates/debian/controller00.interface.j2 b/xci/playbooks/roles/configure-network/templates/debian/controller00.interface.j2
index b461b201..c540f66e 100644
--- a/xci/playbooks/roles/configure-network/templates/debian/controller00.interface.j2
+++ b/xci/playbooks/roles/configure-network/templates/debian/controller00.interface.j2
@@ -5,23 +5,23 @@ auto lo
iface lo inet loopback
# Physical interface
-auto {{ interface }}
-iface {{ interface }} inet manual
+auto {{ ansible_default_ipv4.interface }}
+iface {{ ansible_default_ipv4.interface }} inet manual
# Container/Host management VLAN interface
-auto {{ interface }}.10
-iface {{ interface }}.10 inet manual
- vlan-raw-device {{ interface }}
+auto {{ ansible_default_ipv4.interface }}.10
+iface {{ ansible_default_ipv4.interface }}.10 inet manual
+ vlan-raw-device {{ ansible_default_ipv4.interface }}
# OpenStack Networking VXLAN (tunnel/overlay) VLAN interface
-auto {{ interface }}.30
-iface {{ interface }}.30 inet manual
- vlan-raw-device {{ interface }}
+auto {{ ansible_default_ipv4.interface }}.30
+iface {{ ansible_default_ipv4.interface }}.30 inet manual
+ vlan-raw-device {{ ansible_default_ipv4.interface }}
# Storage network VLAN interface (optional)
-auto {{ interface }}.20
-iface {{ interface }}.20 inet manual
- vlan-raw-device {{ interface }}
+auto {{ ansible_default_ipv4.interface }}.20
+iface {{ ansible_default_ipv4.interface }}.20 inet manual
+ vlan-raw-device {{ ansible_default_ipv4.interface }}
# Container/Host management bridge
auto br-mgmt
@@ -29,7 +29,7 @@ iface br-mgmt inet static
bridge_stp off
bridge_waitport 0
bridge_fd 0
- bridge_ports {{ interface }}.10
+ bridge_ports {{ ansible_default_ipv4.interface }}.10
address {{host_info[inventory_hostname].MGMT_IP}}
netmask 255.255.252.0
@@ -39,7 +39,7 @@ iface br-vxlan inet static
bridge_stp off
bridge_waitport 0
bridge_fd 0
- bridge_ports {{ interface }}.30
+ bridge_ports {{ ansible_default_ipv4.interface }}.30
address {{host_info[inventory_hostname].VXLAN_IP}}
netmask 255.255.252.0
@@ -49,7 +49,7 @@ iface br-vlan inet static
bridge_stp off
bridge_waitport 0
bridge_fd 0
- bridge_ports {{ interface }}
+ bridge_ports {{ ansible_default_ipv4.interface }}
address {{host_info[inventory_hostname].VLAN_IP}}
netmask 255.255.255.0
gateway 192.168.122.1
@@ -69,6 +69,6 @@ iface br-storage inet static
bridge_stp off
bridge_waitport 0
bridge_fd 0
- bridge_ports {{ interface }}.20
+ bridge_ports {{ ansible_default_ipv4.interface }}.20
address {{host_info[inventory_hostname].STORAGE_IP}}
netmask 255.255.252.0