summaryrefslogtreecommitdiffstats
path: root/result_collection_api/opnfv_testapi/tornado_swagger_ui/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'result_collection_api/opnfv_testapi/tornado_swagger_ui/setup.py')
-rw-r--r--result_collection_api/opnfv_testapi/tornado_swagger_ui/setup.py30
1 files changed, 30 insertions, 0 deletions
diff --git a/result_collection_api/opnfv_testapi/tornado_swagger_ui/setup.py b/result_collection_api/opnfv_testapi/tornado_swagger_ui/setup.py
new file mode 100644
index 0000000..57dc48a
--- /dev/null
+++ b/result_collection_api/opnfv_testapi/tornado_swagger_ui/setup.py
@@ -0,0 +1,30 @@
+try:
+ from setuptools import setup
+except ImportError:
+ from distutils.core import setup
+
+with open('README') as f:
+ long_description = f.read()
+
+setup(name='tornado-swagger',
+ version='1.0',
+ url='https://github.com/SerenaFeng/tornado-swagger',
+ zip_safe=False,
+ packages=['tornado_swagger'],
+ package_data={
+ 'tornado_swagger': [
+ 'static/*.*',
+ 'static/css/*.*',
+ 'static/images/*.*',
+ 'static/lib/*.*',
+ 'static/lib/shred/*.*'
+ ]
+ },
+ description='Extract swagger specs from your tornado project',
+ author='Serena Feng',
+ license='MIT',
+ long_description=long_description,
+ install_requires=[
+ 'tornado>=3.1',
+ 'epydoc>=0.3.1'
+ ])