summaryrefslogtreecommitdiffstats
path: root/testapi/setup.py
diff options
context:
space:
mode:
authorSerenaFeng <feng.xiaowei@zte.com.cn>2017-08-25 17:56:55 +0800
committerSerenaFeng <feng.xiaowei@zte.com.cn>2017-08-25 18:05:51 +0800
commitdfd85dece56f1b5f1addac121dcd5438f2c3774b (patch)
tree4084b9035019af1386e1e1c90678a6fdb0228375 /testapi/setup.py
parent2eb503cb2e3496131c21954506da58b056c8fb46 (diff)
leverage setup.py directly to install TestAPI
1. delete additional script install.sh 2. using 'python setup.py install' directly to install TestAPI, as traditional python project do Change-Id: Ifcdee7b2bae2553f523a722bff794c40d20f81cc Signed-off-by: SerenaFeng <feng.xiaowei@zte.com.cn>
Diffstat (limited to 'testapi/setup.py')
-rw-r--r--testapi/setup.py9
1 files changed, 8 insertions, 1 deletions
diff --git a/testapi/setup.py b/testapi/setup.py
index f689cb3..dd52373 100644
--- a/testapi/setup.py
+++ b/testapi/setup.py
@@ -1,5 +1,7 @@
-import setuptools
+import os
+import subprocess
+import setuptools
__author__ = 'serena'
@@ -8,6 +10,11 @@ try:
except ImportError:
pass
+dirpath = os.path.dirname(os.path.abspath(__file__))
+subprocess.call(['ln', '-s',
+ '{}/3rd_party/static'.format(dirpath),
+ '{}/opnfv_testapi/static'.format(dirpath)])
+
setuptools.setup(
setup_requires=['pbr==2.0.0'],
pbr=True)