aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorRoss Brattain <ross.b.brattain@intel.com>2017-06-21 14:57:13 -0700
committerRoss Brattain <ross.b.brattain@intel.com>2017-06-28 23:08:14 -0700
commiteceefe7114bc5d0fc94ac77ee4e510c94c1a76bf (patch)
treecf24e060a2972701c3b6788ed0ed748c8168fe0f /setup.py
parentf2149d0366a2dd7add11d017679307256632d372 (diff)
add Python3 support with six
switch to relative imports for package file use absolute imports in main this requires renaming anteater.py to main.py to avoid absolute import name conflict update setup.py to indicate python 3.4 support Change-Id: I0fcaf8a9825557962dc98a6a4eef490051fbbfb0 Signed-off-by: Ross Brattain <ross.b.brattain@intel.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py7
1 files changed, 5 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 47d1b19..d392231 100755
--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,5 @@
# -*- coding: utf-8 -*-
+from __future__ import absolute_import
import re
import sys
from setuptools.command.test import test as TestCommand
@@ -37,7 +38,7 @@ def find_version(fname):
raise RuntimeError('Cannot find version information')
return version
-__version__ = find_version("anteater/anteater.py")
+__version__ = find_version("anteater/main.py")
def read(fname):
@@ -64,6 +65,8 @@ setup(
'Natural Language :: English',
"Programming Language :: Python :: 2",
'Programming Language :: Python :: 2.7',
+ "Programming Language :: Python :: 3",
+ 'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy'
],
@@ -71,7 +74,7 @@ setup(
py_modules=["anteater"],
entry_points={
'console_scripts': [
- "anteater = anteater.anteater:main"
+ "anteater = anteater.main:main"
]
},
tests_require=['pytest'],