summaryrefslogtreecommitdiffstats
path: root/apigateway/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'apigateway/setup.py')
-rw-r--r--apigateway/setup.py29
1 files changed, 29 insertions, 0 deletions
diff --git a/apigateway/setup.py b/apigateway/setup.py
new file mode 100644
index 0000000..79b3a7d
--- /dev/null
+++ b/apigateway/setup.py
@@ -0,0 +1,29 @@
+#
+# Licensed under the Apache License, Version 2.0 (the "License"); you may
+# not use this file except in compliance with the License. You may obtain
+# a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS, WITHOUT
+# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the
+# License for the specific language governing permissions and limitations
+# under the License.
+
+# -*- coding: utf-8 -*-
+
+import setuptools
+
+
+# In python < 2.7.4, a lazy loading of package `pbr` will break
+# setuptools if some other modules registered functions in `atexit`.
+# solution from: http://bugs.python.org/issue15881#msg170215
+try:
+ import multiprocessing # noqa
+except ImportError:
+ pass
+
+
+setuptools.setup(
+ setup_requires=['pbr'], pbr=True)