summaryrefslogtreecommitdiffstats
path: root/opnfv-theme/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'opnfv-theme/setup.py')
-rw-r--r--opnfv-theme/setup.py30
1 files changed, 30 insertions, 0 deletions
diff --git a/opnfv-theme/setup.py b/opnfv-theme/setup.py
new file mode 100644
index 000000000..55f55bc92
--- /dev/null
+++ b/opnfv-theme/setup.py
@@ -0,0 +1,30 @@
+from setuptools import setup, find_packages
+
+from sphinx_opnfv_theme import __version__
+
+
+setup(
+ name='sphinx_opnfv_theme',
+ description="OPNFV Theme for Sphinx",
+ long_description=open('README.rst').read(),
+ url='https://docs.opnfv.org/',
+ author='Trevor Bramwell',
+ author_email='tbramwell@linuxfoundation.org',
+ version=__version__,
+ entry_points={
+ 'sphinx.html_themes': [
+ 'opnfv = sphinx_opnfv_theme',
+ ]
+ },
+ packages=find_packages(),
+ install_requires=[
+ 'sphinx_bootstrap_theme',
+ 'sphinxcontrib-httpdomain',
+ ],
+ include_package_data=True,
+ package_data={'sphinx_opnfv_theme': [
+ 'theme.conf',
+ 'static/*',
+ '*.html',
+ ]},
+)