summaryrefslogtreecommitdiffstats
path: root/opnfv-theme/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'opnfv-theme/setup.py')
-rw-r--r--opnfv-theme/setup.py18
1 files changed, 9 insertions, 9 deletions
diff --git a/opnfv-theme/setup.py b/opnfv-theme/setup.py
index 5375c0940..55f55bc92 100644
--- a/opnfv-theme/setup.py
+++ b/opnfv-theme/setup.py
@@ -2,29 +2,29 @@ from setuptools import setup, find_packages
from sphinx_opnfv_theme import __version__
-with open('README.rst') as f:
- readme_text = f.read()
setup(
name='sphinx_opnfv_theme',
description="OPNFV Theme for Sphinx",
- long_description=readme_text,
+ long_description=open('README.rst').read(),
url='https://docs.opnfv.org/',
author='Trevor Bramwell',
author_email='tbramwell@linuxfoundation.org',
version=__version__,
- entry_points = {
+ entry_points={
'sphinx.html_themes': [
'opnfv = sphinx_opnfv_theme',
]
},
packages=find_packages(),
- install_requires = [
+ install_requires=[
'sphinx_bootstrap_theme',
- 'sphinxcontrib.httpdomain',
+ 'sphinxcontrib-httpdomain',
],
include_package_data=True,
- package_data = {
- 'sphinx_opnfv_theme': ['opnfv/**',]
- },
+ package_data={'sphinx_opnfv_theme': [
+ 'theme.conf',
+ 'static/*',
+ '*.html',
+ ]},
)