summaryrefslogtreecommitdiffstats
path: root/opnfv-theme/setup.py
diff options
context:
space:
mode:
authorSofia Wallin <sofia.wallin@ericsson.com>2018-04-23 15:18:56 +0000
committerGerrit Code Review <gerrit@opnfv.org>2018-04-23 15:18:56 +0000
commit98fa6c92ed1326896671e23dac2f470c96e471ca (patch)
tree4ed3a273d8ddc66d50fb4c39fa8fd7fdce7e957a /opnfv-theme/setup.py
parentf39141858f45df25e7cb77a51442135cae33c52e (diff)
parentbd331b2451a17eaf5ed8f6fc8aa89f0499031c28 (diff)
Merge "Update OPNFV Sphinx Theme"
Diffstat (limited to 'opnfv-theme/setup.py')
-rw-r--r--opnfv-theme/setup.py18
1 files changed, 9 insertions, 9 deletions
diff --git a/opnfv-theme/setup.py b/opnfv-theme/setup.py
index 5375c0940..55f55bc92 100644
--- a/opnfv-theme/setup.py
+++ b/opnfv-theme/setup.py
@@ -2,29 +2,29 @@ from setuptools import setup, find_packages
from sphinx_opnfv_theme import __version__
-with open('README.rst') as f:
- readme_text = f.read()
setup(
name='sphinx_opnfv_theme',
description="OPNFV Theme for Sphinx",
- long_description=readme_text,
+ long_description=open('README.rst').read(),
url='https://docs.opnfv.org/',
author='Trevor Bramwell',
author_email='tbramwell@linuxfoundation.org',
version=__version__,
- entry_points = {
+ entry_points={
'sphinx.html_themes': [
'opnfv = sphinx_opnfv_theme',
]
},
packages=find_packages(),
- install_requires = [
+ install_requires=[
'sphinx_bootstrap_theme',
- 'sphinxcontrib.httpdomain',
+ 'sphinxcontrib-httpdomain',
],
include_package_data=True,
- package_data = {
- 'sphinx_opnfv_theme': ['opnfv/**',]
- },
+ package_data={'sphinx_opnfv_theme': [
+ 'theme.conf',
+ 'static/*',
+ '*.html',
+ ]},
)