aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorHarry Huang <huangxiangyu5@huawei.com>2017-03-16 18:38:19 +0800
committerHarry Huang <huangxiangyu5@huawei.com>2017-03-16 20:11:46 +0800
commit8a07bcd6b75f62c7c79504f8a3c020a2d635156e (patch)
tree45556730180ab0ac9ab3ad7fb1631acc6d82556a /setup.py
parentfb510361bcf5ddae5b0812d94e89e387bfbe6c59 (diff)
Add upload packages retry
1. retry 5 times if csar package uploads fail 2. clearwater service name varies over the time 3. use the word vnf instead of app Change-Id: Id85c7f467cbefbc46fd1f1daf6202d89ef3ac898 Signed-off-by: Harry Huang <huangxiangyu5@huawei.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py22
1 files changed, 22 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..46bb5fb
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,22 @@
+##############################################################################
+# Copyright (c) 2016-2017 HUAWEI TECHNOLOGIES CO.,LTD and others.
+#
+# All rights reserved. This program and the accompanying materials
+# are made available under the terms of the Apache License, Version 2.0
+# which accompanies this distribution, and is available at
+# http://www.apache.org/licenses/LICENSE-2.0
+##############################################################################
+
+from setuptools import setup, find_packages
+
+
+setup(
+ name="opera",
+ version="master",
+ packages=find_packages(),
+ include_package_data=True,
+ package_data={
+ },
+ url="https://www.opnfv.org",
+ install_requires=["requests==2.9.1"]
+)