aboutsummaryrefslogtreecommitdiffstats
path: root/framework/src/openstack/neutron/plugin/networking-onos/networking-onos/setup.py
diff options
context:
space:
mode:
authorAshlee Young <ashlee@onosfw.com>2015-10-30 09:20:45 -0700
committerAshlee Young <ashlee@onosfw.com>2015-10-30 09:20:45 -0700
commit89a574196783f93e32d81244f37f726be11bbf30 (patch)
tree408c721579d29d49eebf50c78b7f4a8da7a6489e /framework/src/openstack/neutron/plugin/networking-onos/networking-onos/setup.py
parent62bb467ca10e4fd0ca23499953bc7f7f413dee16 (diff)
New ML2/L3 plugin to support SFC
Change-Id: Ie778a2b2e09a29972e28d70c8eedee407b1d8eb6 Signed-off-by: Ashlee Young <ashlee@onosfw.com>
Diffstat (limited to 'framework/src/openstack/neutron/plugin/networking-onos/networking-onos/setup.py')
-rw-r--r--framework/src/openstack/neutron/plugin/networking-onos/networking-onos/setup.py29
1 files changed, 29 insertions, 0 deletions
diff --git a/framework/src/openstack/neutron/plugin/networking-onos/networking-onos/setup.py b/framework/src/openstack/neutron/plugin/networking-onos/networking-onos/setup.py
new file mode 100644
index 00000000..782bb21f
--- /dev/null
+++ b/framework/src/openstack/neutron/plugin/networking-onos/networking-onos/setup.py
@@ -0,0 +1,29 @@
+# Copyright (c) 2013 Hewlett-Packard Development Company, L.P.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+# implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
+import setuptools
+
+# In python < 2.7.4, a lazy loading of package `pbr` will break
+# setuptools if some other modules registered functions in `atexit`.
+# solution from: http://bugs.python.org/issue15881#msg170215
+try:
+ import multiprocessing # noqa
+except ImportError:
+ pass
+
+setuptools.setup(
+ setup_requires=['pbr>=1.8'],
+ pbr=True)