aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorCédric Ollivier <cedric.ollivier@orange.com>2022-12-14 19:23:34 +0100
committerCédric Ollivier <cedric.ollivier@orange.com>2022-12-15 11:13:50 +0100
commit76c6d3deb39045eec4bf11d189892485e8a9c454 (patch)
tree478f35c41335d915edfc625c19ff4d8b87b903e3 /setup.py
parent1278ef65bd3422c0684007535742c3ef28d645ef (diff)
Update to py38
py38 is the oldest py version support vs Ubuntu 22.04 python third-party. It updates requirements to yoga too. Signed-off-by: Cédric Ollivier <cedric.ollivier@orange.com> Change-Id: I9d39f3600a4d0c432b7caf2f0b2bd51554e12318
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py28
1 files changed, 5 insertions, 23 deletions
diff --git a/setup.py b/setup.py
index bf772f3..f63cc23 100644
--- a/setup.py
+++ b/setup.py
@@ -13,27 +13,9 @@
# See the License for the specific language governing permissions and
# limitations under the License.
-from setuptools.command.test import test
-from setuptools import setup
-import sys
+# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
+import setuptools
-
-class Tox(test):
- def initialize_options(self):
- test.initialize_options(self)
- self.tox_args = None
-
- def finalize_options(self):
- test.finalize_options(self)
- self.test_args = []
- self.test_suite = True
-
- def run_tests(self):
- import tox
- sys.exit(tox.cmdline())
-
-
-if __name__ == '__main__':
- setup(setup_requires=['pbr'], pbr=True,
- tests_require=['tox'],
- cmdclass={'test': Tox})
+setuptools.setup(
+ setup_requires=['pbr>=2.0.0'],
+ pbr=True)