aboutsummaryrefslogtreecommitdiffstats
path: root/moon_utilities/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'moon_utilities/setup.py')
-rw-r--r--moon_utilities/setup.py58
1 files changed, 58 insertions, 0 deletions
diff --git a/moon_utilities/setup.py b/moon_utilities/setup.py
new file mode 100644
index 00000000..f5fa746f
--- /dev/null
+++ b/moon_utilities/setup.py
@@ -0,0 +1,58 @@
+# Software Name: MOON
+
+# Version: 5.4
+
+# SPDX-FileCopyrightText: Copyright (c) 2018-2020 Orange and its contributors
+# SPDX-License-Identifier: Apache-2.0
+
+# This software is distributed under the 'Apache License 2.0',
+# the text of which is available at 'http://www.apache.org/licenses/LICENSE-2.0.txt'
+# or see the "LICENSE" file for more details.
+
+
+from setuptools import setup, find_packages
+import moon_utilities
+
+with open('requirements.txt') as f:
+ required = list(filter(
+ lambda s: (len(s.strip()) > 0 and s.strip()[0] != '#'),
+ f.read().split('\n')))
+
+setup(
+
+ name='moon_utilities',
+
+ version=moon_utilities.__version__,
+
+ packages=find_packages(),
+
+ author='Thomas Duval',
+
+ author_email='thomas.duval@orange.com',
+
+ description='Some utilities for all the Moon components',
+
+ long_description=open('README.md').read(),
+
+ install_requires=required,
+
+ include_package_data=True,
+
+ url='',
+
+ classifiers=[
+ 'Programming Language :: Python :: 3',
+ 'Development Status :: 1 - Planning',
+ 'License :: OSI Approved',
+ 'Natural Language :: English',
+ 'Operating System :: OS Independent',
+ ],
+
+ entry_points={
+ 'console_scripts': [
+ 'generate_opst_policy = moon_utilities.generate_opst_policy:main',
+ ],
+
+ }
+
+)