aboutsummaryrefslogtreecommitdiffstats
path: root/moonv4/python_moonclient/setup.py
diff options
context:
space:
mode:
authorRHE <rebirthmonkey@gmail.com>2017-12-21 10:06:52 +0100
committerThomas Duval <thomas.duval@orange.com>2017-12-21 10:33:15 +0100
commit8b326a5aeb0f9655ff0ebfe0d87ff1ea8f66bc38 (patch)
tree16f319475de8f256914e18a6be0183b48ccc692a /moonv4/python_moonclient/setup.py
parenta7f99c33c0b2b2c617dd044e658a263ae910b53a (diff)
python_moonclient init
Change-Id: Iaf104b3208a07dc80cc266830be444d019b0f196 Signed-off-by: RHE <rebirthmonkey@gmail.com>
Diffstat (limited to 'moonv4/python_moonclient/setup.py')
-rw-r--r--moonv4/python_moonclient/setup.py42
1 files changed, 42 insertions, 0 deletions
diff --git a/moonv4/python_moonclient/setup.py b/moonv4/python_moonclient/setup.py
new file mode 100644
index 00000000..000e87ca
--- /dev/null
+++ b/moonv4/python_moonclient/setup.py
@@ -0,0 +1,42 @@
+# Copyright 2015 Open Platform for NFV Project, Inc. and its contributors
+# This software is distributed under the terms and conditions of the 'Apache-2.0'
+# license which can be found in the file 'LICENSE' in this package distribution
+# or at 'http://www.apache.org/licenses/LICENSE-2.0'.
+
+from setuptools import setup, find_packages
+import python_moonclient
+
+with open('requirements.txt') as f:
+ required = f.read().splitlines()
+
+setup(
+
+ name='python-moonclient',
+
+ version=python_moonclient.__version__,
+
+ packages=find_packages(),
+
+ author='Thomas Duval & Ruan He',
+
+ author_email='thomas.duval@orange.com, ruan.he@orange.com',
+
+ description='client lib for all the Moon components',
+
+ long_description=open('README.md').read(),
+
+ install_requires=required,
+
+ include_package_data=True,
+
+ url='https://git.opnfv.org/cgit/moon',
+
+ classifiers=[
+ 'Programming Language :: Python :: 3',
+ 'Development Status :: 1 - Planning',
+ 'License :: OSI Approved',
+ 'Natural Language :: English',
+ 'Operating System :: OS Independent',
+ ],
+
+)