aboutsummaryrefslogtreecommitdiffstats
path: root/external_policy_checker/setup.py
diff options
context:
space:
mode:
authorThomas Duval <thomas.duval@orange.com>2018-03-07 10:53:41 +0100
committerThomas Duval <thomas.duval@orange.com>2018-03-07 10:57:14 +0100
commit9a2e6721376547244e53dbb92ea596f526a9c865 (patch)
tree0c9377c1af969864a740072fb442aa4847ca274e /external_policy_checker/setup.py
parentdbd38cc0f28257772580d42905d2d398fc1d1705 (diff)
Add Moon stub for the tempest and patrole tests.
Change-Id: Icb3cc72f69636b3a99a3c7c19be3c4e407cb24dc
Diffstat (limited to 'external_policy_checker/setup.py')
-rw-r--r--external_policy_checker/setup.py47
1 files changed, 47 insertions, 0 deletions
diff --git a/external_policy_checker/setup.py b/external_policy_checker/setup.py
new file mode 100644
index 00000000..acd994a6
--- /dev/null
+++ b/external_policy_checker/setup.py
@@ -0,0 +1,47 @@
+# Copyright 2015 Open Platform for NFV Project, Inc. and its contributors
+# This software is distributed under the terms and conditions of the 'Apache-2.0'
+# license which can be found in the file 'LICENSE' in this package distribution
+# or at 'http://www.apache.org/licenses/LICENSE-2.0'.
+
+from setuptools import setup, find_packages
+import external_policy_checker
+
+
+setup(
+
+ name='external_policy_checker',
+
+ version=external_policy_checker.__version__,
+
+ packages=find_packages(),
+
+ author="Thomas Duval",
+
+ author_email="thomas.duval@orange.com",
+
+ description="",
+
+ long_description=open('README.md').read(),
+
+ install_requires=["flask"],
+
+ include_package_data=True,
+
+ url='https://git.opnfv.org/cgit/moon',
+
+ classifiers=[
+ "Programming Language :: Python",
+ "Development Status :: 1 - Planning",
+ "License :: OSI Approved",
+ "Natural Language :: French",
+ "Operating System :: OS Independent",
+ "Programming Language :: Python :: 3",
+ ],
+
+ entry_points={
+ 'console_scripts': [
+ 'external_policy_checker = external_policy_checker.server:main',
+ ],
+ }
+
+)