summaryrefslogtreecommitdiffstats
path: root/fuel/build/patch-packages/python-nova/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'fuel/build/patch-packages/python-nova/Makefile')
-rw-r--r--fuel/build/patch-packages/python-nova/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/fuel/build/patch-packages/python-nova/Makefile b/fuel/build/patch-packages/python-nova/Makefile
new file mode 100644
index 0000000..fbf5fb4
--- /dev/null
+++ b/fuel/build/patch-packages/python-nova/Makefile
@@ -0,0 +1,29 @@
+##############################################################################
+# Copyright (c) 2015 Ericsson AB and others.
+# stefan.k.berg@ericsson.com
+# jonas.bjurel@ericsson.com
+# All rights reserved. This program and the accompanying materials
+# are made available under the terms of the Apache License, Version 2.0
+# which accompanies this distribution, and is available at
+# http://www.apache.org/licenses/LICENSE-2.0
+##############################################################################
+
+TOP := $(shell pwd)
+
+.PHONY: all
+all:
+
+.PHONY: clean
+clean:
+ @rm -rf package
+ @rm -rf *.deb
+ @rm -rf patch-replacements
+ @rm -rf .package
+
+.PHONY: release
+release:
+ ../tools/deb_unpack python-nova_*.deb $(ORIGISO)
+ patch -s -p0 < nova-console.patch
+ ../tools/deb_pack $(REVSTATE)
+ @cp *.deb ../release/packages
+ @cat patch-replacements >> ../release/patch-replacements