summaryrefslogtreecommitdiffstats
path: root/fuel/build/patch-packages/novnc/Makefile
diff options
context:
space:
mode:
authorMichal Skalski <mskalski@mirantis.com>2015-05-18 14:57:00 +0000
committerMichal Skalski <mskalski@mirantis.com>2015-05-18 16:04:42 +0000
commitcae1a185c6d66f34b1f16f9f0e20f55e8d330346 (patch)
tree2b98d45fe8487e8a774bfaf2903cd7a609bdc88b /fuel/build/patch-packages/novnc/Makefile
parent2debee7a4f97a6a9d90aa55877264b3c62e3e2df (diff)
Patch novnc ubuntu package
Patch novnc ubuntu package by adding missing files. Related bug: https://bugs.launchpad.net/fuel/+bug/1433894 Change-Id: Iba413c664bb93dea26245c9ed4471fff30e43968 Jira: - Signed-off-by: Michal Skalski <mskalski@mirantis.com>
Diffstat (limited to 'fuel/build/patch-packages/novnc/Makefile')
-rw-r--r--fuel/build/patch-packages/novnc/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/fuel/build/patch-packages/novnc/Makefile b/fuel/build/patch-packages/novnc/Makefile
new file mode 100644
index 0000000..16c0196
--- /dev/null
+++ b/fuel/build/patch-packages/novnc/Makefile
@@ -0,0 +1,22 @@
+# This is a temporary patch which add missing files
+# inside novnc ubuntu package.
+# Related bug: https://bugs.launchpad.net/fuel/+bug/1433894
+TOP := $(shell pwd)
+
+.PHONY: all
+all:
+
+.PHONY: clean
+clean:
+ @rm -rf package
+ @rm -rf *.deb
+ @rm -rf patch-replacements
+ @rm -rf .package
+
+.PHONY: release
+release:
+ ../tools/deb_unpack novnc_0.5.1*.deb $(ORIGISO)
+ ./fix-missing.sh
+ ../tools/deb_pack $(REVSTATE)
+ @cp *.deb ../release/packages
+ @cat patch-replacements >> ../release/patch-replacements