summaryrefslogtreecommitdiffstats
path: root/fuel/build/patch-packages/debootstrap
diff options
context:
space:
mode:
authorStefan K. Berg <stefan.k.berg@ericsson.com>2015-09-10 14:46:28 +0200
committerStefan K. Berg <stefan.k.berg@ericsson.com>2015-09-10 14:46:28 +0200
commit5d4a36b80fcd0b69e35e4d4f59cfb64a62453c28 (patch)
tree623d5b318601c7105896d083c1f0fe2120ec05fa /fuel/build/patch-packages/debootstrap
parentc92ee8677af0dba1b9f28bc9a97cbf141d60e219 (diff)
Refactoring build system to support Fuel 6.1
As Fuel 6.1 has changed both Debian package handling (fetching repositories from Internet) as well as Puppet packaging, the support for patching these has been disabled. The pre-deploy logic of Fuel has been removed together with a number of patches applied on top of a Fuel build, among them fixes for NTP, DNS and /etc/hosts injection. Instead, when changed default behavior is required, this will be introduced as Fuel plugins which more cleanly integrates into the Fuel system, and also decouples additional functionality from the ISO build stage. Signed-off-by: Stefan K. Berg <stefan.k.berg@ericsson.com>
Diffstat (limited to 'fuel/build/patch-packages/debootstrap')
-rw-r--r--fuel/build/patch-packages/debootstrap/Makefile28
-rw-r--r--fuel/build/patch-packages/debootstrap/debootstrap.patch12
2 files changed, 0 insertions, 40 deletions
diff --git a/fuel/build/patch-packages/debootstrap/Makefile b/fuel/build/patch-packages/debootstrap/Makefile
deleted file mode 100644
index 0109312..0000000
--- a/fuel/build/patch-packages/debootstrap/Makefile
+++ /dev/null
@@ -1,28 +0,0 @@
-##############################################################################
-# Copyright (c) 2015 Ericsson AB and others.
-# stefan.k.berg@ericsson.com
-# jonas.bjurel@ericsson.com
-# All rights reserved. This program and the accompanying materials
-# are made available under the terms of the Apache License, Version 2.0
-# which accompanies this distribution, and is available at
-# http://www.apache.org/licenses/LICENSE-2.0
-##############################################################################
-
-TOP := $(shell pwd)
-
-.PHONY: all
-all:
-
-.PHONY: clean
-clean:
- @rm -rf udebPackage
- @rm -rf *.udeb
- @rm -rf patch-replacements
- @rm -rf .udebpackage
-
-.PHONY: release
-release:
- ../tools/udeb_unpack debootstrap-udeb_1.0.4*.udeb $(ORIGISO)
- patch -s -p0 < debootstrap.patch
- ../tools/udeb_pack $(REVSTATE)
- @cp *.udeb $(UDEB_DEST)
diff --git a/fuel/build/patch-packages/debootstrap/debootstrap.patch b/fuel/build/patch-packages/debootstrap/debootstrap.patch
deleted file mode 100644
index 62342c9..0000000
--- a/fuel/build/patch-packages/debootstrap/debootstrap.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- udebPackage/usr/share/debootstrap/scripts/gutsy.orig 2014-11-10 18:21:37.000000000 +0000
-+++ udebPackage/usr/share/debootstrap/scripts/gutsy 2015-04-15 09:28:44.290437000 +0000
-@@ -112,7 +112,8 @@
-
- p; progress $baseprog $bases INSTCORE "Installing core packages" #2
- ln -sf mawk "$TARGET/usr/bin/awk"
-- x_core_install base-files base-passwd
-+ x_core_install base-passwd
-+ x_core_install base-files
- p; progress $baseprog $bases INSTCORE "Installing core packages" #3
- x_core_install dpkg
-