summaryrefslogtreecommitdiffstats
path: root/fuel/build/patch-packages/Makefile
diff options
context:
space:
mode:
authorStefan K. Berg <stefan.k.berg@ericsson.com>2015-09-10 14:46:28 +0200
committerStefan K. Berg <stefan.k.berg@ericsson.com>2015-09-10 14:46:28 +0200
commit5d4a36b80fcd0b69e35e4d4f59cfb64a62453c28 (patch)
tree623d5b318601c7105896d083c1f0fe2120ec05fa /fuel/build/patch-packages/Makefile
parentc92ee8677af0dba1b9f28bc9a97cbf141d60e219 (diff)
Refactoring build system to support Fuel 6.1
As Fuel 6.1 has changed both Debian package handling (fetching repositories from Internet) as well as Puppet packaging, the support for patching these has been disabled. The pre-deploy logic of Fuel has been removed together with a number of patches applied on top of a Fuel build, among them fixes for NTP, DNS and /etc/hosts injection. Instead, when changed default behavior is required, this will be introduced as Fuel plugins which more cleanly integrates into the Fuel system, and also decouples additional functionality from the ISO build stage. Signed-off-by: Stefan K. Berg <stefan.k.berg@ericsson.com>
Diffstat (limited to 'fuel/build/patch-packages/Makefile')
-rw-r--r--fuel/build/patch-packages/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/fuel/build/patch-packages/Makefile b/fuel/build/patch-packages/Makefile
index bd3a437..339c9e7 100644
--- a/fuel/build/patch-packages/Makefile
+++ b/fuel/build/patch-packages/Makefile
@@ -8,7 +8,7 @@
# http://www.apache.org/licenses/LICENSE-2.0
##############################################################################
-SUBDIRS := debootstrap novnc neutron-common
+SUBDIRS :=
SUBCLEAN = $(addsuffix .clean,$(SUBDIRS))
.PHONY: $(SUBDIRS) $(SUBCLEAN) clean