aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorhelenyao <yaohelan@huawei.com>2016-11-13 21:10:06 -0500
committerhelenyao <yaohelan@huawei.com>2016-11-13 21:23:41 -0500
commit56a8a8c2ca7092eec328cbfc462d6c6a984e05e6 (patch)
tree391a418feaf1d271a7d56100331dd476d466054c /setup.py
parentf9fbe4211144a556820bb0933709224ff3fa90c0 (diff)
Wrap the Functest and install it as module by pip.
JIRA: FUNCTEST-538 1. PYTHONPATH is removed. 2. Functest will be installed by pip. 3. Dockerfile is updated accordingly. Change-Id: Ie4eed9df045b121e2688dcb34c25779db775f104 Signed-off-by: helenyao <yaohelan@huawei.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py51
1 files changed, 29 insertions, 22 deletions
diff --git a/setup.py b/setup.py
index c192bd93b..872b08913 100644
--- a/setup.py
+++ b/setup.py
@@ -1,22 +1,29 @@
-##############################################################################
-# All rights reserved. This program and the accompanying materials
-# are made available under the terms of the Apache License, Version 2.0
-# which accompanies this distribution, and is available at
-# http://www.apache.org/licenses/LICENSE-2.0
-##############################################################################
-
-from setuptools import setup, find_packages
-
-
-setup(
- name="functest",
- version="master",
- packages=find_packages(),
- include_package_data=True,
- package_data={
- },
- url="https://www.opnfv.org",
- install_requires=["coverage==4.1",
- "mock==1.3.0",
- "nose==1.3.7"],
-)
+##############################################################################
+# All rights reserved. This program and the accompanying materials
+# are made available under the terms of the Apache License, Version 2.0
+# which accompanies this distribution, and is available at
+# http://www.apache.org/licenses/LICENSE-2.0
+##############################################################################
+
+from setuptools import setup, find_packages
+
+
+setup(
+ name="functest",
+ version="master",
+ py_modules=['cli_base'],
+ packages=find_packages(),
+ include_package_data=True,
+ package_data={
+ },
+ url="https://www.opnfv.org",
+ install_requires=["coverage==4.1",
+ "mock==1.3.0",
+ "nose==1.3.7",
+ "click"],
+ entry_points={
+ 'console_scripts': [
+ 'functest=functest.cli.cli_base:cli'
+ ],
+ },
+)