aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorCédric Ollivier <cedric.ollivier@orange.com>2017-06-04 20:05:50 +0200
committerCédric Ollivier <cedric.ollivier@orange.com>2017-06-07 11:34:45 +0200
commit53f6c3948e048fd8c639704a385f4beae01ebfd9 (patch)
tree0b5912410d65037322af2e52bb0f9fba825b4a9f /setup.py
parent6c6b03b310cf60b251a52127901431f7d059e45f (diff)
Leverage on pbr (Python Build Reasonableness)
pbr can inject requirements into the install_requires, tests_require and/or dependency_links arguments to setup. They were previously falsy unset. It also supports conditional dependencies which can be added to the requirements (e.g. subprocess32; python_version=='2.7'). Then requirements.py3.txt is removed. It also removes functest/cli/setup.py which seems false and obsolete. Dockerfile is updated as well. One temporarily link is created because of several hardcoded paths in Functest. Change-Id: I14b3b25e07fbac490dd1d5ce943ec02c5b11f242 Signed-off-by: Cédric Ollivier <cedric.ollivier@orange.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py24
1 files changed, 8 insertions, 16 deletions
diff --git a/setup.py b/setup.py
index 0c53ffbc9..460651cfd 100644
--- a/setup.py
+++ b/setup.py
@@ -1,25 +1,17 @@
-##############################################################################
+#!/usr/bin/env python
+
+# Copyright (c) 2017 Orange and others.
+#
# All rights reserved. This program and the accompanying materials
# are made available under the terms of the Apache License, Version 2.0
# which accompanies this distribution, and is available at
# http://www.apache.org/licenses/LICENSE-2.0
-##############################################################################
-from setuptools import setup, find_packages
+# pylint: disable=missing-docstring
+from setuptools import setup
setup(
- name="functest",
- version="master",
- py_modules=['cli_base'],
- packages=find_packages(),
- include_package_data=True,
- package_data={
- },
- url="https://www.opnfv.org",
- entry_points={
- 'console_scripts': [
- 'functest=functest.cli.cli_base:cli'
- ],
- },
+ setup_requires=['pbr>=1.9', 'setuptools>=17.1'],
+ pbr=True,
)