aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authordjkonro <konraddjimeli@gmail.com>2018-01-14 16:19:05 +0100
committerdjkonro <konraddjimeli@gmail.com>2018-01-24 10:06:08 +0100
commit2a36556281b2d95f6d24da9bd02baa611724faf1 (patch)
treeea123cf60c25368635ef88dd042469f4cd62c77a /setup.py
parentad86868d3740c6ec4a7da0a7a6126fc0385d6d1b (diff)
Add initial python class for kubernetes testing
JIRA: FUNCTEST-904 Co-Authored-By: Cédric Ollivier <cedric.ollivier@orange.com> Change-Id: I9007e4e6f58118d1b09774d0acbb2a315437e09a Signed-off-by: djkonro <konraddjimeli@gmail.com> Signed-off-by: Cédric Ollivier <cedric.ollivier@orange.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py29
1 files changed, 29 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 00000000..566d8443
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,29 @@
+# Copyright (c) 2013 Hewlett-Packard Development Company, L.P.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+# implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
+import setuptools
+
+# In python < 2.7.4, a lazy loading of package `pbr` will break
+# setuptools if some other modules registered functions in `atexit`.
+# solution from: http://bugs.python.org/issue15881#msg170215
+try:
+ import multiprocessing # noqa
+except ImportError:
+ pass
+
+setuptools.setup(
+ setup_requires=['pbr>=2.0.0'],
+ pbr=True)