summaryrefslogtreecommitdiffstats
path: root/fuel/build/patch-packages/novnc
diff options
context:
space:
mode:
Diffstat (limited to 'fuel/build/patch-packages/novnc')
-rw-r--r--fuel/build/patch-packages/novnc/Makefile22
-rwxr-xr-xfuel/build/patch-packages/novnc/fix-missing.sh9
2 files changed, 0 insertions, 31 deletions
diff --git a/fuel/build/patch-packages/novnc/Makefile b/fuel/build/patch-packages/novnc/Makefile
deleted file mode 100644
index 16c0196e9..000000000
--- a/fuel/build/patch-packages/novnc/Makefile
+++ /dev/null
@@ -1,22 +0,0 @@
-# This is a temporary patch which add missing files
-# inside novnc ubuntu package.
-# Related bug: https://bugs.launchpad.net/fuel/+bug/1433894
-TOP := $(shell pwd)
-
-.PHONY: all
-all:
-
-.PHONY: clean
-clean:
- @rm -rf package
- @rm -rf *.deb
- @rm -rf patch-replacements
- @rm -rf .package
-
-.PHONY: release
-release:
- ../tools/deb_unpack novnc_0.5.1*.deb $(ORIGISO)
- ./fix-missing.sh
- ../tools/deb_pack $(REVSTATE)
- @cp *.deb ../release/packages
- @cat patch-replacements >> ../release/patch-replacements
diff --git a/fuel/build/patch-packages/novnc/fix-missing.sh b/fuel/build/patch-packages/novnc/fix-missing.sh
deleted file mode 100755
index 61ef1db14..000000000
--- a/fuel/build/patch-packages/novnc/fix-missing.sh
+++ /dev/null
@@ -1,9 +0,0 @@
-#!/bin/bash
-
-MISSING_FILES="keyboard.js keysymdef.js keysym.js"
-NOVNC_SOURCE="http://raw.githubusercontent.com/kanaka/noVNC/v0.5.1/include"
-
-for file in $MISSING_FILES
-do
- wget -P package/usr/share/novnc/include/ "$NOVNC_SOURCE/$file"
-done