diff options
author | hongbo tian <hongbo.tianhongbo@huawei.com> | 2017-04-05 06:21:54 +0000 |
---|---|---|
committer | Gerrit Code Review <gerrit@opnfv.org> | 2017-04-05 06:21:54 +0000 |
commit | 4bb7cb467da755537d8f51be1a7966bc6700afad (patch) | |
tree | e7c68118bfb4a216a6440e9069895ac7efc627b3 /setup.py | |
parent | 065f48efe1961a26e990bc5d5eab50036dff3ff9 (diff) | |
parent | 33cdf9599104a610e2681614ec010a4c2a8ac112 (diff) |
Merge "bugfix of pbr after updating"
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 8 |
1 files changed, 8 insertions, 0 deletions
@@ -9,6 +9,14 @@ import setuptools +# In python < 2.7.4, a lazy loading of package `pbr` will break +# setuptools if some other modules registered functions in `atexit`. +# solution from: http://bugs.python.org/issue15881#msg170215 +try: + import multiprocessing # noqa +except ImportError: + pass + setuptools.setup( setup_requires=['pbr==2.0.0'], pbr=True) |