aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorCédric Ollivier <cedric.ollivier@orange.com>2017-08-18 16:20:33 +0200
committerCédric Ollivier <cedric.ollivier@orange.com>2017-09-02 14:32:49 +0200
commitb5ac0a412e1958cdff581d14b818bf042293267f (patch)
tree6b261838744963cceb60235bef39bf35cc8e86c0 /setup.py
parent21f973902ee4428462564d27719f366b41ce04c5 (diff)
Add domino package
It's required by Functest to ease integrating all OPNFV projects and their requirements. It also synchronizes requirements with stable/ocata and renames domino-cli to domino_cli to conform with common module names. It defines scripts and console_scripts to rely on $PATH. run_multimode.sh is adapted to correctly call client, cli and server. It should be noted that run.sh can raise conflicts if it's already provided by another OPNFV package and that run_on_remote_nodes.sh is not fully updated. Otherwise it obliges all OPNFV installers to be updated as well. run.sh is unchanged and it's called by releng from local directory. It may rise runtime issues if several files are not loaded via pkg_resources. Change-Id: Ibd9dd56f316609180aa432c6b7ee5a375d9af674 Signed-off-by: Cédric Ollivier <cedric.ollivier@orange.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py22
1 files changed, 22 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..a1e9b3b
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,22 @@
+#!/usr/bin/env python
+
+# Copyright (c) 2017 Orange and others.
+#
+# All rights reserved. This program and the accompanying materials
+# are made available under the terms of the Apache License, Version 2.0
+# which accompanies this distribution, and is available at
+# http://www.apache.org/licenses/LICENSE-2.0
+
+import setuptools
+
+# In python < 2.7.4, a lazy loading of package `pbr` will break
+# setuptools if some other modules registered functions in `atexit`.
+# solution from: http://bugs.python.org/issue15881#msg170215
+try:
+ import multiprocessing # noqa
+except ImportError:
+ pass
+
+setuptools.setup(
+ setup_requires=['pbr>=1.8'],
+ pbr=True)