summaryrefslogtreecommitdiffstats
path: root/cli/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'cli/setup.py')
-rw-r--r--cli/setup.py26
1 files changed, 26 insertions, 0 deletions
diff --git a/cli/setup.py b/cli/setup.py
new file mode 100644
index 00000000..28314910
--- /dev/null
+++ b/cli/setup.py
@@ -0,0 +1,26 @@
+#!/usr/bin/env python
+##############################################################################
+# Copyright (c) 2016 Huawei Technologies Co.,Ltd and others.
+#
+# All rights reserved. This program and the accompanying materials
+# are made available under the terms of the Apache License, Version 2.0
+# which accompanies this distribution, and is available at
+# http://www.apache.org/licenses/LICENSE-2.0
+##############################################################################
+
+from setuptools import setup
+
+setup(
+ name='bottlenecks',
+ version='0.1',
+ py_modules=['bottlenecks_cli'],
+ include_package_data=True,
+ install_requires=[
+ 'click',
+ ],
+ entry_points='''
+ [console_scripts]
+ bottlenecks=bottlenecks_cli:main
+ ''',
+)
+