summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorxudan <xudan16@huawei.com>2019-11-01 02:46:47 -0400
committerxudan <xudan16@huawei.com>2019-11-01 02:46:47 -0400
commitb6c7bba0c071b42172283e4d97a3641f6464857a (patch)
treedbebefc54a5d406c4c8c3c28cd417192797290b2
parent1b563bff1a09aa3f32286844b9549156baadf5a9 (diff)
Fix the version of more-itertools to be 5.0.0HEADstable/iruyamaster
The default version of more-itertools installed is 7.2.0 which should be latest. While this version doesn't support python 2.7 and will get an error: File "/usr/local/lib/python2.7/dist-packages/more_itertools/more.py", line 340 def _collate(*iterables, key=lambda a: a, reverse=False): ^ SyntaxError: invalid syntax In order to support python2.7, it needs to be <=5.0.0. Signed-off-by: xudan <xudan16@huawei.com> Change-Id: I4567e0742246e2d5539cefd2d112a2022c979ca8
-rw-r--r--requirements/requirements.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/requirements/requirements.txt b/requirements/requirements.txt
index 87bd238..19218fd 100644
--- a/requirements/requirements.txt
+++ b/requirements/requirements.txt
@@ -20,3 +20,4 @@ elasticsearch==5.0.1
docker==2.0.2
kubernetes==6.0.0
urllib3==1.24
+more-itertools==5.0.0