aboutsummaryrefslogtreecommitdiffstats
path: root/baro_tests
diff options
context:
space:
mode:
authorEmma Foley <emma.l.foley@intel.com>2018-02-27 18:07:08 +0000
committerEmma Foley <emma.l.foley@intel.com>2018-02-27 18:13:09 +0000
commit24ebbf843134491d430e9d1140837f30a111c0be (patch)
tree0dc05ebd31212cc26a21dc35c6e31692e2e2c97e /baro_tests
parent7f4ef61d68c3ed96759f3553b2793e0ce6a7e4a5 (diff)
Fix syntax error in baro_test/collectd.py:mcelog_install
The version of CentOS that's used no longer matches the version that is explicitly checked in collectd.py:mcelog_install. As a result the code on L637-L642[1] is now being called. This code was syntactically incorrect, however, was previously not being called, witht eh update to the version, it is now being executed and causing failures in deployment [2]. [1] https://github.com/opnfv/barometer/blob/c10400426df872be3236677dcb749c755f4a559c/baro_tests/collectd.py#L637-L642 [2] https://build.opnfv.org/ci/job/functest-apex-baremetal-daily-master/809/consoleText Change-Id: I35274d4ede17510c3ae03c756eda7bc9f78b4e17 Signed-off-by: Emma Foley <emma.l.foley@intel.com>
Diffstat (limited to 'baro_tests')
-rw-r--r--baro_tests/collectd.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/baro_tests/collectd.py b/baro_tests/collectd.py
index 304b87b..bf310f0 100644
--- a/baro_tests/collectd.py
+++ b/baro_tests/collectd.py
@@ -636,9 +636,9 @@ def mcelog_install():
centos_release = node.run_cmd('uname -r')
if '3.10.0-514.26.2.el7.x86_64' not in centos_release:
logger.info(
- 'Mcelog will not be enabled '
- + 'on node-{0}, '.format(node.get_dict()['name'])
- + 'unsupported CentOS release found ({1}).'.format(
+ 'Mcelog will not be enabled on node-{}, ' +
+ ' unsupported CentOS relase found ({}).'.format(
+ node.get_dict()['name'],
centos_release))
else:
logger.info(