aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py28
1 files changed, 28 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..c7ec804
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,28 @@
+#!/usr/bin/env python
+########################################################################
+# Copyright (c) 2018 Huawei Technologies Co.,Ltd and others.
+#
+# All rights reserved. This program and the accompanying materials
+# are made available under the terms of the Apache License, Version 2.0
+# which accompanies this distribution, and is available at
+# http://www.apache.org/licenses/LICENSE-2.0
+########################################################################
+
+import os
+from setuptools import setup, find_packages
+
+__author__ = "Harry Huang <huangxiangyu5@huawei.com>"
+
+
+requirement_path = os.path.join(
+ os.path.dirname(__file__), 'requirements.txt')
+with open(requirement_path, 'r') as fd:
+ requirements = [line.strip() for line in fd if line != '\n']
+
+setup(
+ name="auto",
+ version='1.0.0',
+ packages=find_packages(),
+ include_package_data=True,
+ install_requires=requirements
+)