summaryrefslogtreecommitdiffstats
path: root/build/opnfv-apex.spec
diff options
context:
space:
mode:
authorDan Radez <dradez@redhat.com>2016-01-11 15:07:04 -0500
committerMichael Chapman <woppin@gmail.com>2016-01-15 20:49:50 +1100
commit90c5cf6da143cfe4f50eace12251934ebd29a239 (patch)
treefd4087c9759a8f0da8eaa53473974e35d05be42e /build/opnfv-apex.spec
parentc29cb27c644733e5d2fc50c67426cf15e4cd84b3 (diff)
splitting rpm into multiple rpms
- code in the common rpm - instack in the instack rpm - undercloud in an rpm that will be named per sdn in the future Change-Id: I969277daf87f67da6934cad7268c96efda6960c7
Diffstat (limited to 'build/opnfv-apex.spec')
-rw-r--r--build/opnfv-apex.spec87
1 files changed, 9 insertions, 78 deletions
diff --git a/build/opnfv-apex.spec b/build/opnfv-apex.spec
index e2ae7181..ebe87897 100644
--- a/build/opnfv-apex.spec
+++ b/build/opnfv-apex.spec
@@ -1,105 +1,36 @@
Name: opnfv-apex
Version: 2.1
Release: %{release}
-Summary: Scripts and Disk images for deployment
+Summary: Overcloud Disk images for OPNFV Apex OpenDaylight deployment
Group: System Environment
License: Apache 2.0
URL: https://gerrit.opnfv.org/gerrit/apex.git
Source0: opnfv-apex.tar.gz
+Provides: opnfv-apex-sdn
BuildArch: noarch
-BuildRequires: openvswitch qemu-kvm python-docutils
-Requires: openvswitch qemu-kvm bridge-utils libguestfs-tools
+Requires: opnfv-apex-common opnfv-apex-undercloud
+Conflicts: opnfv-apex-onos opnfv-apex-opencontrail
%description
-These files are scripts and disk images used to launch the instack
-libvirt VM and to load into the instack undercloud machine
-to deploy an OpenStack overcloud. Installation is done via RDO Manager
-https://rdoproject.org
+Overcloud Disk images for OPNFV Apex OpenDaylight deployment
+https://wiki.opnfv.org/apex
%prep
%setup -q
-
-%build
-rst2html docs/installation-instructions/installation-instructions.rst docs/installation-instructions.html
-rst2html docs/release-notes/index.rst docs/release-notes.html
-
%install
-mkdir -p %{buildroot}%{_bindir}/
-install ci/deploy.sh %{buildroot}%{_bindir}/opnfv-deploy
-install ci/clean.sh %{buildroot}%{_bindir}/opnfv-clean
-
mkdir -p %{buildroot}%{_var}/opt/opnfv/stack/
-mkdir -p %{buildroot}%{_var}/opt/opnfv/nics/
-mkdir -p %{buildroot}%{_var}/opt/opnfv/lib/
-
-install lib/common-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
-install build/instack.qcow2 %{buildroot}%{_var}/opt/opnfv/stack/
-install build/instack.xml %{buildroot}%{_var}/opt/opnfv/
-install build/baremetalbrbm_brbm1_brbm2_brbm3_*.xml %{buildroot}%{_var}/opt/opnfv/
-install build/brbm-net.xml %{buildroot}%{_var}/opt/opnfv/
-install build/brbm1-net.xml %{buildroot}%{_var}/opt/opnfv/
-install build/brbm2-net.xml %{buildroot}%{_var}/opt/opnfv/
-install build/brbm3-net.xml %{buildroot}%{_var}/opt/opnfv/
-install build/default-pool.xml %{buildroot}%{_var}/opt/opnfv/
-install build/network-environment.yaml %{buildroot}%{_var}/opt/opnfv/
-install build/nics/controller.yaml %{buildroot}%{_var}/opt/opnfv/nics/
-install build/nics/compute.yaml %{buildroot}%{_var}/opt/opnfv/nics/
-install build/nics/controller_private.yaml %{buildroot}%{_var}/opt/opnfv/nics/
-install build/nics/compute_private.yaml %{buildroot}%{_var}/opt/opnfv/nics/
-install build/nics/controller_storage.yaml %{buildroot}%{_var}/opt/opnfv/nics/
-install build/nics/compute_storage.yaml %{buildroot}%{_var}/opt/opnfv/nics/
-install build/nics/controller_private_storage.yaml %{buildroot}%{_var}/opt/opnfv/nics/
-install build/nics/compute_private_storage.yaml %{buildroot}%{_var}/opt/opnfv/nics/
-
-install build/instackenv-virt.json %{buildroot}%{_var}/opt/opnfv/
-install build/instackenv.json.example %{buildroot}%{_var}/opt/opnfv/
install build/stack/overcloud-full.qcow2 %{buildroot}%{_var}/opt/opnfv/stack/
-mkdir -p %{buildroot}%{_docdir}/opnfv/
-install LICENSE.rst %{buildroot}%{_docdir}/opnfv/
-install docs/installation-instructions/index.rst %{buildroot}%{_docdir}/opnfv/installation-instructions.rst
-install docs/installation-instructions.html %{buildroot}%{_docdir}/opnfv/
-install docs/release-notes/index.rst %{buildroot}%{_docdir}/opnfv/release-notes.rst
-install docs/release-notes.html %{buildroot}%{_docdir}/opnfv/
-install config/deploy/deploy_settings.yaml %{buildroot}%{_docdir}/opnfv/deploy_settings.yaml.example
-install config/deploy/network/network_settings.yaml %{buildroot}%{_docdir}/opnfv/network_settings.yaml.example
-
%files
-%{_bindir}/opnfv-deploy
-%{_bindir}/opnfv-clean
-%{_var}/opt/opnfv/lib/common-functions.sh
-%{_var}/opt/opnfv/stack/instack.qcow2
-%{_var}/opt/opnfv/instack.xml
-%{_var}/opt/opnfv/baremetalbrbm_brbm1_brbm2_brbm3_*.xml
-%{_var}/opt/opnfv/brbm-net.xml
-%{_var}/opt/opnfv/brbm1-net.xml
-%{_var}/opt/opnfv/brbm2-net.xml
-%{_var}/opt/opnfv/brbm3-net.xml
-%{_var}/opt/opnfv/default-pool.xml
-%{_var}/opt/opnfv/network-environment.yaml
-%{_var}/opt/opnfv/nics/controller.yaml
-%{_var}/opt/opnfv/nics/compute.yaml
-%{_var}/opt/opnfv/nics/controller_private.yaml
-%{_var}/opt/opnfv/nics/compute_private.yaml
-%{_var}/opt/opnfv/nics/controller_storage.yaml
-%{_var}/opt/opnfv/nics/compute_storage.yaml
-%{_var}/opt/opnfv/nics/controller_private_storage.yaml
-%{_var}/opt/opnfv/nics/compute_private_storage.yaml
-%{_var}/opt/opnfv/instackenv-virt.json
-%{_var}/opt/opnfv/instackenv.json.example
+%defattr(644, root, root, -)
%{_var}/opt/opnfv/stack/overcloud-full.qcow2
-%doc %{_docdir}/opnfv/LICENSE.rst
-%doc %{_docdir}/opnfv/installation-instructions.rst
-%doc %{_docdir}/opnfv/installation-instructions.html
-%doc %{_docdir}/opnfv/release-notes.rst
-%doc %{_docdir}/opnfv/release-notes.html
-%doc %{_docdir}/opnfv/deploy_settings.yaml.example
-%doc %{_docdir}/opnfv/network_settings.yaml.example
%changelog
+* Thu Jan 14 2016 Dan Radez <dradez@redhat.com> - 2.1-2
+- Package Split
* Wed Jan 13 2016 Dan Radez <dradez@redhat.com> - 2.1-1
- Incrementing Minor for Bramaputra RC release
* Sun Dec 20 2015 Tim Rozet <trozet@redhat.com> - 2.0-8