summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFeng Pan <fpan@redhat.com>2018-04-14 18:34:38 -0400
committerFeng Pan <fpan@redhat.com>2018-04-14 18:36:20 -0400
commit1abb8ac25c48d182bc267d23f618043fbd7e0843 (patch)
tree631b1e2344e9abc58eb4aec1d88237b12c41fedc
parent0cd3c6cef32adb1bf9d26414ed73bd9373b0c407 (diff)
Fix barometer install failure
We are seeing pip3 not found and collectd-write_sensu package conflicts with latest pike overcloud images. This patch changes pip3 install to python34-pip3 and updates collectd-write_sensu package version when removing. Change-Id: I7dfe1f2f39c3f21bffde8cfc6066f5bae66677d6 Signed-off-by: Feng Pan <fpan@redhat.com>
-rwxr-xr-xbuild/barometer-install.sh8
1 files changed, 3 insertions, 5 deletions
diff --git a/build/barometer-install.sh b/build/barometer-install.sh
index 2391b6b..0ea401d 100755
--- a/build/barometer-install.sh
+++ b/build/barometer-install.sh
@@ -89,9 +89,8 @@ function barometer_pkgs {
wget $GETFLAG $ARTIFACTS_BAROM/$BAROMETER_VER/collectd-netlink-${SUFFIX}
wget $GETFLAG $ARTIFACTS_BAROM/$BAROMETER_VER/collectd-rrdtool-${SUFFIX}
wget $GETFLAG $ARTIFACTS_BAROM/$BAROMETER_VER/collectd-lvm-${SUFFIX}
- curl "https://bootstrap.pypa.io/get-pip.py" -o "get-pip.py"
- tar cfz collectd.tar.gz *.rpm get-pip.py
+ tar cfz collectd.tar.gz *.rpm
cp collectd.tar.gz ${BUILD_DIR}
popd > /dev/null
@@ -126,17 +125,16 @@ function barometer_pkgs {
--upload ${BUILD_DIR}/puppet-barometer.tar.gz:/etc/puppet/modules/ \
--run-command 'tar xfz /opt/collectd.tar.gz -C /opt' \
--install libstatgrab,log4cplus,rrdtool,rrdtool-devel \
- --install mcelog,python34,python34-libs,python34-devel \
+ --install mcelog,python34,python34-libs,python34-devel,python34-pip \
--install libvirt,libvirt-devel,gcc \
-a $OVERCLOUD_IMAGE
LIBGUESTFS_BACKEND=direct $VIRT_CUSTOMIZE \
- --run-command 'python3.4 /opt/get-pip.py' \
--run-command 'pip3 install requests libvirt-python pbr babel future six' \
-a $OVERCLOUD_IMAGE
LIBGUESTFS_BACKEND=direct $VIRT_CUSTOMIZE \
- --run-command 'yum remove -y collectd-write_sensu-5.8.0-2.el7.x86_64' \
+ --run-command 'yum remove -y collectd-write_sensu-5.8.0-3.el7.x86_64' \
-a $OVERCLOUD_IMAGE
LIBGUESTFS_BACKEND=direct $VIRT_CUSTOMIZE \