aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorOpenStack Proposal Bot <openstack-infra@lists.openstack.org>2017-01-10 09:44:01 +0000
committerOpenStack Proposal Bot <openstack-infra@lists.openstack.org>2017-01-10 09:44:01 +0000
commit216aa0d4dbe24e49414e1cff7d565963dfee73b3 (patch)
treea8db43ae7e6cc8337f7e40453f23b56f48acb8bd /setup.py
parent8f02a77ad4d3a157702603818b7548f2a98fc9d0 (diff)
Updated from global requirements
Change-Id: I9ae60dfb2ef5e8fb5aae482ddb08206fc1980ca5
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py11
1 files changed, 9 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 70c2b3f3..782bb21f 100644
--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,3 @@
-#!/usr/bin/env python
# Copyright (c) 2013 Hewlett-Packard Development Company, L.P.
#
# Licensed under the Apache License, Version 2.0 (the "License");
@@ -17,6 +16,14 @@
# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools
+# In python < 2.7.4, a lazy loading of package `pbr` will break
+# setuptools if some other modules registered functions in `atexit`.
+# solution from: http://bugs.python.org/issue15881#msg170215
+try:
+ import multiprocessing # noqa
+except ImportError:
+ pass
+
setuptools.setup(
- setup_requires=['pbr'],
+ setup_requires=['pbr>=1.8'],
pbr=True)