aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorLuke Hinds <lhinds@redhat.com>2016-12-02 11:12:03 +0000
committerLuke Hinds <lhinds@redhat.com>2016-12-03 13:16:33 +0000
commitfb0436eee322eca0432a66f78ae5abb5700fa727 (patch)
tree31d48767ae81c9fb2cb30cceed7f1380fa99aa6c /setup.py
parent915fc62398d2311b7e43dfd564dccb8a400b21f8 (diff)
Add basic structure for ReNo
ReNo [1] is the release management tool in OpenStack. This patch adds the basic structure to start using it for doc builds in puppet-tripleo. * Update .gitignore * Add a basic note "use-reno" * Add releasenotes/ dir and basic files * Add python files: setup.cfg, setup.py, test-requirements.txt and tox.ini. [1] http://docs.openstack.org/developer/reno Change-Id: Idc9a30ab632c8e2ca794fb10431cdefd5d861d14
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py22
1 files changed, 22 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..7eeb36b
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,22 @@
+#!/usr/bin/env python
+# Copyright (c) 2013 Hewlett-Packard Development Company, L.P.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+# implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
+import setuptools
+
+setuptools.setup(
+ setup_requires=['pbr'],
+ pbr=True) \ No newline at end of file