diff options
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 9 |
1 files changed, 7 insertions, 2 deletions
@@ -10,16 +10,17 @@ setup( include_package_data=True, package_data={ 'yardstick': [ + 'benchmark/scenarios/compute/*.bash', 'benchmark/scenarios/networking/*.bash', 'benchmark/scenarios/storage/*.bash', 'resources/files/*' - ] + ] }, url="https://www.opnfv.org", install_requires=["backport_ipaddress", # remove with python3 "flake8", "PyYAML>=3.10", - "pbr!=0.7,<1.0,>=0.6", + "pbr<2.0,>=1.3", "python-glanceclient>=0.12.0", "python-heatclient>=0.2.12", "python-keystoneclient>=0.11.1", @@ -29,9 +30,13 @@ setup( "paramiko", "six" ], + extras_require={ + 'plot': ["matplotlib>=1.4.2"] + }, entry_points={ 'console_scripts': [ 'yardstick=yardstick.main:main', + 'yardstick-plot=yardstick.plot.plotter:main [plot]' ], }, scripts=['tools/yardstick-img-modify'] |