aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py10
1 files changed, 9 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 495291cef..eb55e9283 100755
--- a/setup.py
+++ b/setup.py
@@ -8,9 +8,14 @@ setup(
include_package_data=True,
package_data={
'yardstick': [
- 'benchmark/scenarios/availability/ha_tools/*.bash',
+ 'benchmark/scenarios/availability/attacker/*.yaml',
+ 'benchmark/scenarios/availability/attacker/scripts/*.bash',
+ 'benchmark/scenarios/availability/monitor/*.yaml',
+ 'benchmark/scenarios/availability/monitor/script_tools/*.bash',
'benchmark/scenarios/compute/*.bash',
'benchmark/scenarios/networking/*.bash',
+ 'benchmark/scenarios/networking/*.txt',
+ 'benchmark/scenarios/parser/*.sh',
'benchmark/scenarios/storage/*.bash',
'resources/files/*'
]
@@ -20,6 +25,7 @@ setup(
"coverage>=3.6",
"flake8",
"Jinja2>=2.6",
+ "lxml",
"PyYAML>=3.10",
"pbr<2.0,>=1.3",
"python-glanceclient>=0.12.0",
@@ -30,9 +36,11 @@ setup(
"mock>=1.0.1", # remove with python3
"paramiko",
"netifaces",
+ "scp",
"six",
"testrepository>=0.0.18",
"testtools>=1.4.0"
+ "nose"
],
extras_require={
'plot': ["matplotlib>=1.4.2"]