aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorHou Jingwen <houjingwen@huawei.com>2015-11-05 09:03:09 +0000
committerGerrit Code Review <gerrit@172.30.200.206>2015-11-05 09:03:09 +0000
commit71413bb440af953d20a0dfc52ef710ea1618cd90 (patch)
treeb102e3483d045a6e8d459f6c41094b0db7c1bdf0 /setup.py
parent7209b9b3f9aedaba4ed1ae91c78641a29d84ba0c (diff)
parent607148f8e4eb4ebb443dd5098b4fea5f880f9fbb (diff)
Merge "part 2 :add coverage report in Jenkins for Yardstick"
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index a6848ec63..b8a6fe987 100755
--- a/setup.py
+++ b/setup.py
@@ -16,6 +16,7 @@ setup(
},
url="https://www.opnfv.org",
install_requires=["backport_ipaddress", # remove with python3
+ "coverage>=3.6",
"flake8",
"Jinja2>=2.6",
"PyYAML>=3.10",
@@ -28,7 +29,8 @@ setup(
"mock>=1.0.1", # remove with python3
"paramiko",
"six",
- "testrepository>=0.0.18"
+ "testrepository>=0.0.18",
+ "testtools>=1.4.0"
],
extras_require={
'plot': ["matplotlib>=1.4.2"]