summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorKubi <jean.gaoliang@huawei.com>2016-11-17 07:45:00 +0000
committerGerrit Code Review <gerrit@opnfv.org>2016-11-17 07:45:00 +0000
commiteeeca4f0cdeff152ec061bb9b40ae305547c027e (patch)
treea124f0ec08330a2706ac63e0f052b8bc40ed6334 /setup.py
parent1e132a317acdca7202f009c4d16898705b277665 (diff)
parent02e9da46ba3eed7e4552a30030000459fb56b7da (diff)
Merge "Yardstick installation unified (pip/setup)"
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py31
1 files changed, 5 insertions, 26 deletions
diff --git a/setup.py b/setup.py
index 9bf656bac..6a89d6368 100755
--- a/setup.py
+++ b/setup.py
@@ -32,28 +32,6 @@ setup(
]
},
url="https://www.opnfv.org",
- install_requires=["backport_ipaddress", # remove with python3
- "coverage>=3.6",
- "flake8",
- "Jinja2>=2.6",
- "lxml",
- "PyYAML>=3.10",
- "pbr<2.0,>=1.3",
- "python-openstackclient>=2.1.0",
- "python-glanceclient>=0.12.0",
- "python-heatclient>=0.2.12",
- "python-keystoneclient>=0.11.1",
- "python-neutronclient>=2.3.9",
- "python-novaclient>=2.24.1",
- "mock>=1.0.1", # remove with python3
- "paramiko",
- "netifaces",
- "scp",
- "six",
- "testrepository>=0.0.18",
- "testtools>=1.4.0",
- "nose"
- ],
extras_require={
'plot': ["matplotlib>=1.4.2"]
},
@@ -63,8 +41,9 @@ setup(
'yardstick-plot=yardstick.plot.plotter:main [plot]'
],
},
- scripts=['tools/yardstick-img-modify',
- 'tools/yardstick-img-lxd-modify',
- 'tools/yardstick-img-dpdk-modify'
- ]
+ scripts=[
+ 'tools/yardstick-img-modify',
+ 'tools/yardstick-img-lxd-modify',
+ 'tools/yardstick-img-dpdk-modify'
+ ]
)