summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorkubi <jean.gaoliang@huawei.com>2015-09-15 03:37:14 -0400
committerkubi <jean.gaoliang@huawei.com>2015-09-25 15:32:26 +0800
commit531ac9968cf8703ad7a2c70f45837ce0e81dbec9 (patch)
treeed1a8d5e8bcb1665b49a8521858a1ac6207a5cbf /setup.py
parent735af0fc05d73cbc7bd97b52a230d966cbfec6c3 (diff)
Add functional tests in verify and merge
As Ana said ,"The first functional test should be as simple as a "Hello world", it shall be possible to run the "Hello world" test without using OpenStack." so i just finish functional test framework and do functional test for subcommand "runner"and"scenario" without using Openstack. JIRA:YARDSTICK-103 Change-Id: I673ae61f9922536a685d32ae62e5ad5165472f9d Signed-off-by: kubi <jean.gaoliang@huawei.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index f171aafee..75e589ee3 100755
--- a/setup.py
+++ b/setup.py
@@ -29,7 +29,8 @@ setup(
"python-novaclient>=2.24.1",
"mock>=1.0.1", # remove with python3
"paramiko",
- "six"
+ "six",
+ "testrepository>=0.0.18"
],
extras_require={
'plot': ["matplotlib>=1.4.2"]