summaryrefslogtreecommitdiffstats
path: root/xtesting/openstack/setup.py
diff options
context:
space:
mode:
authoropensource-tnbt <sridhar.rao@spirent.com>2020-11-25 19:30:04 +0530
committeropensource-tnbt <sridhar.rao@spirent.com>2020-11-28 18:51:49 +0530
commit0bbc7e2674bd06921e9fe4a0b3318724327d3ff2 (patch)
treeb8c5bbf7dadf8e6e06adc969bac1d75d5ff2f908 /xtesting/openstack/setup.py
parent54995886ec5135bca580cb81a3ed8fd2eb4bae3a (diff)
[WIP]: VSPERF-Xtesting Integration Support.
This patch adds support for integrationg with Xtesting project There are two variations - baremetal and openstack. Update-1: Add Download-result feature to baremetal Update-2: Update Dockerfile following successful compilations. Update-3: Add Baremetal-Advanced to Migrate to driver version Update-4: Remove Bashfeature approach of Baremetal. Update-5: Update documentation, Baremetal container name and openstack. Update-6: Update Openstack after successful testing Signed-off-by: Sridhar K. N. Rao <sridhar.rao@spirent.com> Change-Id: Idcf9f533a0cc6760ca3e56355e2ff60d41616f0f
Diffstat (limited to 'xtesting/openstack/setup.py')
-rw-r--r--xtesting/openstack/setup.py9
1 files changed, 9 insertions, 0 deletions
diff --git a/xtesting/openstack/setup.py b/xtesting/openstack/setup.py
new file mode 100644
index 00000000..1394cdfe
--- /dev/null
+++ b/xtesting/openstack/setup.py
@@ -0,0 +1,9 @@
+#!/usr/bin/env python
+
+# pylint: disable=missing-docstring
+
+import setuptools
+
+setuptools.setup(
+ setup_requires=['pbr>=2.0.0'],
+ pbr=True)